The subject pretty much says it all, except for the minor fact of using "domain.xml" in the xmlReadDoc(). This cleanup really just makes the code easier to read. Signed-off-by: Chris Lalancette <clalance@xxxxxxxxxx>
Index: src/domain_conf.c =================================================================== RCS file: /data/cvs/libvirt/src/domain_conf.c,v retrieving revision 1.8 diff -u -r1.8 domain_conf.c --- a/src/domain_conf.c 25 Jul 2008 14:27:25 -0000 1.8 +++ b/src/domain_conf.c 25 Jul 2008 16:14:05 -0000 @@ -1396,7 +1396,7 @@ } def->id = -1; - /* Find out what type of QEMU virtualization to use */ + /* Find out what type of virtualization to use */ if (!(tmp = virXPathString(conn, "string(./@type)", ctxt))) { virDomainReportError(conn, VIR_ERR_INTERNAL_ERROR, "%s", _("missing domain type attribute")); @@ -1762,7 +1762,7 @@ } VIR_FREE(nodes); - /* analysis of the input devices */ + /* analysis of the graphics devices */ if ((n = virXPathNodeSet(conn, "./devices/graphics", ctxt, &nodes)) < 0) { virDomainReportError(conn, VIR_ERR_INTERNAL_ERROR, "%s", _("cannot extract graphics devices")); @@ -1847,7 +1847,7 @@ xmlNodePtr root; virDomainDefPtr def = NULL; - if (!(xml = xmlReadDoc(BAD_CAST xmlStr, "network.xml", NULL, + if (!(xml = xmlReadDoc(BAD_CAST xmlStr, "domain.xml", NULL, XML_PARSE_NOENT | XML_PARSE_NONET | XML_PARSE_NOERROR | XML_PARSE_NOWARNING))) { virDomainReportError(conn, VIR_ERR_XML_ERROR, NULL);
-- Libvir-list mailing list Libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list