On Tue, Jun 26, 2007 at 12:00:01PM +0100, Richard W.M. Jones wrote: > Daniel Veillard wrote: > >>I haven't updated the Python bindings, but will do so next. > > > > it's probable that those 2 calles will be handled automatically > >since the arg is a known structure and the return value is a string. > >It's a matter of rebuilding the API xml with the new headers once applied > >and let the generator do its job. > > I'll check. I'm really ill today ... no hurry :-) > >Can we avoid using asprintf, especially in new code, I don't think the > >convenience wins over the portability problem, thanks > >Or it's just a conveninent way to indicate where a new path creation > >routine should be added... > > Even better, can we add asprintf to the code and compile it into libvirt > if configure.in detects that it is absent from libc? Asprintf is really > useful... And then I would not call it asprintf, and would rather have it used on all arches. We need a routine for building paths dynamically, that's where we use asprintf in teh code, and we could do very easilly with a vararg function using a MAX_PATH buffer. Using a specialized function is more in line with the actual code and allows for a simpler implementation. > >>--- src/xen_unified.h 30 Apr 2007 16:57:15 -0000 1.3 > >>+++ src/xen_unified.h 26 Jun 2007 09:51:05 -0000 > >>@@ -50,6 +50,9 @@ struct _xenUnifiedPrivate { > >> * xen_unified.c. > >> */ > >> int opened[XEN_UNIFIED_NR_DRIVERS]; > >>+ > >>+ /* Canonical URI. */ > >>+ char *name; > >> }; > > > > is that the canonical URI or the FQDN ? Maybe the field need to be > > renamed > >(and possibly the comment). > > It's the canonical URI. For example NULL || "xen" -> "xen:///": so let's rename the field to canonical_uri ! Daniel -- Red Hat Virtualization group http://redhat.com/virtualization/ Daniel Veillard | virtualization library http://libvirt.org/ veillard@xxxxxxxxxx | libxml GNOME XML XSLT toolkit http://xmlsoft.org/ http://veillard.com/ | Rpmfind RPM search engine http://rpmfind.net/