Re: Dolphin with fish

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 6/5/22 7:58 AM, Emmett Culley wrote:
Today I attempted to adjust a webserver configuration using dolphin to connect to fish://root@server/etc.  Connection worked as usual and I found I was looking at a listing of the /etc directory.  All good and expected.

Then I clicked on httpd which switched to listing the /etc/httpd directory.  I then clicked on conf.d and got this message at the top of dolphin:

"The file fish://server/etc/httpd/conf.d could not be loaded, as it was not possible to read from it.
Check if you have read access to this file."

And in a pop up dialog I saw this:

"Could not read file fish://server/etc/httpd/conf.d."

On closer inspection I saw that there was no > next to the directory conf.d, which usually means it is not a directory, but the permissions showed drwxr-xr-w.

So I logged into that server via ssh and was able to enter /etc/httpd/conf.d without a problem, and from there edit or view any of the apache config files.

Then I tried renaming the conf.d directory to conf_d from the dolphin fish connection.  Then I was able click on conf_d to descend into that directory and edit any of the apache config files there.

I tried renaming the directory to conf.d and after that was able to descend into that directory from that dolphin session.  Closing dolphin, opening it again and connectin to that server via fish again, I was again not able to get into the/etc/httpd/conf.d directory.

Turns out this happens no matter which server I connect, some of which are Rocky Linux, most are CentOS Stream 8, and two are CentOS 7.  All do the same.  That is, any directory named *.d cannot be decended into via fish on dolpin.

I just upgraded to Fedora 36, and this was not a problem before the upgrade.  I use dolphin multiple times a day to connect to the servers I manage, and this is the first time I saw this.

So my question is, is it possible there is a configuration setting I am missing.  I will fils a bug regardless, but I was hoping there might be a work around.

Filed bug:
kde mailing list -- kde@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to kde-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it:

[Index of Archives]     [KDE Users]     [Fedora General Discussion]     [Older Fedora Users Mail]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Maintainers]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Fedora Triage]     [Coolkey]     [Yum Users]     [Yosemite Forum]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

  Powered by Linux