Re: Plasma on Wayland

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


KDE on Wayland is extremely buggy for me also and a lot of my programs don't work or have major issues. I don't think it's ready to be default and needs a lot of work. Long live X11.

On Mon, Jan 18, 2021 at 3:19 PM Adam Batkin <adam@xxxxxxxxxx> wrote:
Since there is a plan to default Plasma to use Wayland, I thought I'd
offer some feedback based on my testing over the past couple of weeks.

I tested on two different systems, one with an NVidia video card (GTX
750 Ti, using the proprietary driver) and the other being a newer system
with an AMD card (5600 XT, only stock Fedora drivers).

On the NVidia system, the result was clear very early on: It was unusable.

* The mouse cursor sometimes (usually?) had an almost-imperceptible
lag/flicker as it moved, kinda like when one of those fluorescent lights
is starting to die, and you can stare at it for as long as you want but
you can't *see* the flicker, but you know it's happening, and now you
have a migraine
* Bits of Plasma would refuse to paint. For example KRunner (Alt+F2)
would appear, sometimes I could type a letter or two, at which point it
would appear to completely "freeze". Behind-the-scenes, it was still
processing input, and I could arrow around and hit enter (having no idea
what it was doing since I couldn't see anything) and it would launch
whatever happened to be selected that I couldn't see. And next time I
pressed Alt+F2, my previous text was pre-filled, so I knew it was
working. There were other little Plasma things that worked similarly
* Firefox and Thunderbird (X11-mode) worked, until suddenly they stopped
working and turned into a big black box. Usually that was it until I
rebooted, but sometimes if I resized something, I could get it to snap
out of it and come back to life. Firefox with Wayland-mode was worse, as
it would flash violently (even when not doing anything) - I assume
trying to give someone a seizure.

On to the AMD system. Things were "mostly" working, but I've still
switched back to X11 because I need to get real work done.

* I can't use CopyQ - oh well. I switched back to Klipper, which I
hadn't used in like a decade. It's not terrible, and if this was my only
issue, I'd survive
* Something isn't right with the clipboard. Usually I'd copy something
and then I could immediately paste it. But sometimes I'd paste and my
clipboard was empty. So I'd Alt+Tab back to wherever I was, copy again,
and then it would work. I did some searching, and there have been lots
of complaints about clipboard issues like this going back 3+ years, with
various different behaviors, suggested fixes, etc... but nothing
concrete. Maybe it's a conflict with something klipper is doing (but
honestly, if I can't use a clipboard manager at all, I can't use
Wayland). Usually I'd copy from Firefox (X11) to a konsole terminal so
that's where most of the "failures" happened, but once or twice it was
from one konsole window to another (note: I use
* Some sort of kernel panic on startup, that didn't seem to affect
functionality: (I
haven't seen this again since switching back to X11)
* Firefox: X11-mode is fine. Wayland-mode caused terrible flicker making
it unusable
* JetBrains products (i.e. Java/Swing-based, IntelliJ IDEA
specifically): Everything mostly worked, except occasionally it would
open a dialog (like a file selector) and the whole UI would appear to
freeze (it's a modal dialog after all, but the dialog hadn't "appeared"
yet so there was nothing I could interact with). I'd minimize the whole
IDE and bring it back, and usually after that or some other similar
black-magic incantation, when it restored, the dialog would be present
and I could carry on. I don't have a specific way of reproducing this,
and every time I'd go back and try to re-open the same exact dialog in
the same way, it would be fine
* The thing that finally got me to switch back was when, in the middle
of compiling something, kwin_wayland crashed, killing the whole session.
If I had to guess, it had something to do with the fact that it was
painting/scrolling the konsole window VERY fast during compilation and
it got angry. I tried using the oops reporter thing, but it complained
about something not working, so I gave up. I've put the system under
load for plenty of other things (and I can dual-boot to Windows and
stress-test the system for an hour and it's fine with temps hovering
around ambient)

In summary: On my AMD-based system, Wayland is _almost_ there. But this
combination of intermittent problems makes me hesitant to use it as my
daily-driver. Life is good under X11 for me: things are fast and stable
and boring, which is just perfect. I'm happy to do more testing (i.e.
run for a couple days under Wayland) to do more testing at some point,
but not for day-to-day work.

I hope this is helpful.

-Adam Batkin

kde mailing list -- kde@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to kde-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
kde mailing list -- kde@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to kde-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:

[Index of Archives]     [KDE Users]     [Fedora General Discussion]     [Older Fedora Users Mail]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Maintainers]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Fedora Triage]     [Coolkey]     [Yum Users]     [Yosemite Forum]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

  Powered by Linux