Hi Thierry, my consideration follows (a github-like platform with inline comments would be really welcome)! = method naming and placement = 1- I would use the following convention: if a method setup a functionality adding various entries to the tree, I would name it "setup" and hopefully should be placed DSAdminTools. 2- methods like _createDefaultReplMgr are not expected to be used in production, so should be placed in the DSAdminTools section 3- the brooker naming convention is based on the "function-first" so that python interactive users can tab and autocomplete it. initAgreement should be renamed to something like agreement_init or something else. For the return codes, simply use exceptions. = exception handling & None return = 1- in case of errors, a method should raise a proper exception and eventually log the error 2- so the assert clauses should be replaced by exception because they mean that something went wrong and an action should be taken 3- about the bindmethod stuff: see http://pastebin.com/w0WnVQuJ There are some other points but the best way to set them is with patches. Let me know + Peace, R. On Wednesday 13 November 2013 17:06:25 thierry bordaz wrote: > In order to implement the first CI test with replication instances, I > reorganised lib389 functions related to replication setup. > > https://fedorahosted.org/389/attachment/ticket/47590/0001-Ticket-47590-CI-te > sts-add-split-functions-around-rep.patch -- Roberto Polli Community Manager Babel S.r.l. - http://www.babel.it T: +39.06.9826.9651 M: +39.340.652.2736 F: +39.06.9826.9680 P.zza S.Benedetto da Norcia, 33 - 00040 Pomezia (Roma) CONFIDENZIALE: Questo messaggio ed i suoi allegati sono di carattere confidenziale per i destinatari in indirizzo. E' vietato l'inoltro non autorizzato a destinatari diversi da quelli indicati nel messaggio originale. Se ricevuto per errore, l'uso del contenuto e' proibito; si prega di comunicarlo al mittente e cancellarlo immediatamente. -- 389-devel mailing list 389-devel@xxxxxxxxxxxxxxxxxxxxxxx https://admin.fedoraproject.org/mailman/listinfo/389-devel