Re: Help getting Fedora working on my rpi3

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


So I managed to answer my own question about the kernel arg - it turned out to be necessary to get xfce to run stable. Next issue: no sound. The wiki says the analog audio out is not currently working, but audio over HDMI is, but I can't get either of them to work - I see an analog and a digital out in the pulseaudio mixer, but neither of them actually produces any sound. I've even tried plugging in a usb audio interface (which works seamlessly under Fedora on my x86 desktops), and it shows up in the pulseaudio mixer, but no sound. Any ideas?

Another issue: any media apps which use gstreamer throw errors about not having the right gstreamer plugin (for any/all plugins/formats), despite the fact that all the plugin packages are installed and gst-inspect shows all the codecs you would expect. Not sure if this is an arm/rpi specific issue or specific to this Xfce spin or what

On Wed, Feb 23, 2022 at 10:37 AM Kevin Bowen <kevin.t.bowen@xxxxxxxxx> wrote:
Thanks, I see the xfce spin for aarch64 now, I was looking in the wrong place before. I'm trying it now, and it was able to boot into xfce successfully without having to add the 'cma=192M' karg mentioned in the wiki... is that still necessary/recommended? And if so, is 'grubby --args="cma=192M" --update-kernel=ALL' the correct way to do that?

Kevin Bowen

On Wed, Feb 23, 2022 at 1:01 AM Peter Robinson <pbrobinson@xxxxxxxxx> wrote:
> I'm trying to get Fedora working on my Raspberry Pi 3b+, and have some questions/issues I don't see addressed in the docs. First off, for this hardware, should I be using the aarch64 or armhfp images? I've been trying with aarch64 and that boots, but just wanted to doublecheck. Second, is it possible to get Gnome running? The "hardware status" wiki page says XFce is recommended, but it's not clear whether that means Gnome won't work, or if it's just not recommended. I tried the Workstation image and the firstboot wizard runs successfully, but then when attempting to login, gnome-shell crashes after chugging for a couple minutes and dumps me back at the gdm login screen. I tried adding 'cma=192M' to kernel args as suggested on the wiki, but no change.

You should use aarch64, we're retiring armhfp post F-36. The problem
with GNOME is that you need to allocate 256Mb of RAM for the GPU for
it to work and then remaining ~768Mb doesn't give you a lot of space
to run an OS and app. Given those constraints it works to some
definition of "work".

> If the answer turns out to be the Gnome isn't going to work and I have to go with Xfce, I don't see an Xfce spin built for aarch64, only armhfp, is that correct? Is that what I should be using?

There is XFCE for aarch64.
arm mailing list -- arm@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to arm-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it:

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [Linux ARM (Vger)]     [Linux ARM]     [ARM Kernel]     [Fedora User Discussion]     [Older Fedora Users Discussion]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Maintainers]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Coolkey]     [Yum Users]     [Tux]     [Yosemite News]     [Linux Apps]     [KDE Users]     [Fedora Tools]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

Powered by Linux