Need help in troubleshooting anaconda package installation failure

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


   First of all sorry for long email, but I have been trying out things for two days. I am setting up cobbler for kickstarting machines with our own updates yum repo and while kickstarting (centos 6.7 and also 6.5) anaconda fails at dbus-1.2.24-7 installation with error,
A fatal error occurred when installing the <rpm.hdr object at 0x7fef65f96ed0> package. 

    This is already been noticed and raised and workaround suggested,

     I further checked the apache logs (of yum)  it appears that all the requests has been made to the ISO repo/source-1 (GET /cblr/links/centos6_7-x86_64/Packages/...rpm)  and not a single call is made to the updates repo mirror (I was expecting GET /cobbler/repo_mirror/our_updates_repo/..rpm). This made me think that the updates repo is not enabled by anaconda. So I made sure to set the .treeinfo :), and  with ctrl+alt+f2 I entered into cmd prompt, and started checking logs.

  • yum.log: Has so many lines "marking  An_rpm_in_updates_repo as install for An_rpm_in_main_repo"
  • Checked history /mnt/sysimage/var/lib/yum/history/2016-11-26/1/config-repos: shows the following repos were enabled
i am still not sure about updates repo enabled or not and if enabled why it isn't pulling the rpms ?

Here is a another cobbler which is working fine making requests to our_updates_repo is called during anaconda installation,

GET /cblr/links/centos6_5-x86_64/Packages/ncurses-5.7-3.20090208.el6.x86_64.rpm HTTP/1.1" 206 24160
GET /cblr/links/centos6_5-x86_64/Packages/vim-minimal-7.2.411-1.8.el6.x86_64.rpm HTTP/1.1" 206 6956
GET /cobbler/repo_mirror/our-updates-6_5/glibc-2.12-1.166.el6_7.7.x86_64.rpm HTTP/1.1" 206 217940
GET /cblr/links/centos6_5-x86_64/Packages/shadow-utils- HTTP/1.1" 206 69628
GET /cobbler/repo_mirror/our-updates-6_5/coreutils-8.4-37.el6_7.3.x86_64.rpm HTTP/1.1" 206 101588
GET /cobbler/repo_mirror/our-updates-6_5/bash-4.1.2-15.el6_5.2.x86_64.rpm HTTP/1.1" 206 46364

    Can someone help in understanding how the packages are installed ? Is there a way I can install by hand (I tried downloading the rpms and running rpm -ivh which is not helping). Any ideas why rpms are not pulled from the updates repo ? 

anaconda version : 13.21.215

Thanks in advance
Anaconda-devel-list mailing list

[Index of Archives]     [Kickstart]     [Fedora Users]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]
  Powered by Linux