Hi,
On 08/10/2011 03:23 PM, Martin Gracik wrote:
>
> + def reset_scheduling(self):
> + log.info("dispatch: resetting scheduling")
> + for step in self.steps.keys():
You don't need to call keys() when traversing dictionary keys.
Fixed.
> + try:
> + self.steps[step].unschedule(self._current_step())
The name "_current_step" sounds more like a property,
if it is a method, wouldn't it be better to call it
"_get_current_step" ?
You are right it is a property, also one I want to keep private. I think
I could refactor _current_step() into a property but that just doesn't
fit well into this patch.
Ales
_______________________________________________
Anaconda-devel-list mailing list
Anaconda-devel-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/anaconda-devel-list