> I'm sure it made sense to do it this way when we only had two > possibilities, but now with a third, I'd much prefer that the code to > generate a stanza be a method on an Image subclass. Good suggestion. > > @@ -1905,6 +1939,11 @@ def writeSysconfigKernel(anaconda, > default_kernel): > > f.write("DEFAULTKERNEL=%s\n" % default_kernel) > > f.close() > > > > +def is_trusted_boot(anaconda): > > + if anaconda.backend.ayum.isPackageInstalled(name="tboot"): > > + return True > > + else: > > + return False > > > > def writeBootloader(anaconda): > > """ Write bootloader configuration to disk. > > This could be simplified to just: > > return anaconda.backend.ayum.isPackageInstalled(name="tboot") You are right. Thanks a lot for the comments. BTW, I have a question regarding GRUB2. Shall we do anything else to enable multiboot for GRUB2 in anaconda? Jimmy _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list