> diff --git a/anaconda b/anaconda > index 106928b..ef1c9b6 100755 > --- a/anaconda > +++ b/anaconda > @@ -992,8 +992,11 @@ if __name__ == "__main__": > if anaconda.isKickstart and instClass.ksdata.reboot["eject"]: > isys.flushDriveDict() > for drive in isys.cdromList(): > - log.info("attempting to eject %s" % drive) > - isys.ejectCdrom(drive) > + if not anaconda.noeject: > + log.info("attempting to eject %s" % drive) > + isys.ejectCdrom(drive) > + else: > + log.info("noeject in effect, not ejecting %s" % drive) > > del anaconda.intf Just to be terribly picky, it'd be easier to read this without the double negative: if anaconda.noeject: log.info("noeject in effect...") else: log.info("attempting...") isys.ejectCdrom(drive) - Chris _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list