> > + modName, _ = modline.split(" ", 1) > > "tmp" might be a better name for a temporary variable than "_". Coming from an SML background, using _ as a temporary name doesn't bother me at all. If you wanted to do things in a more pythonic style, you'd probably do: modName = modline.split(" ", 1)[0] My only other comment would be that it'd be nice to use execWithCapture here, but because we want the first column of output, it's going to involve just as much processing. So, not worth it. - Chris _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list