On Thu, 2009-11-26 at 16:53 +0100, Ales Kozumplik wrote: > Previously, the method call was logged into 'tmp/anaconda.log' which > made the file harder to do anything useful with. Looks okay to me with one comment, below. > diff --git a/storage/devices.py b/storage/devices.py > index 7f30d32..c10417c 100644 > --- a/storage/devices.py > +++ b/storage/devices.py > @@ -108,7 +108,8 @@ import platform > import block > > from errors import * > -from iutil import log_method_call, notify_kernel, numeric_type > +from iutil import notify_kernel, numeric_type > +from storage.storage_log import log_method_call > from udev import * > from formats import get_device_format_class, getFormat, DeviceFormat > from isys import compareDrives I think fully qualifying the storage.storage_log module from within the storage module just makes it harder to read, especially when there are relative imports immediately before/after it (udev, formats in the example above). Dave _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list