> diff --git a/iw/partition_gui.py b/iw/partition_gui.py > index 3eaa490..ffdd30b 100644 > --- a/iw/partition_gui.py > +++ b/iw/partition_gui.py > @@ -1265,6 +1265,14 @@ class PartitionWindow(InstallWindow): > self.editLVMLogicalVolume(device) > elif isinstance(device, storage.devices.PartitionDevice): > self.editPartition(device) > + else: > + self.intf.messageWindow(_("Unable to Edit"), > + _("You chose a device that cannot be " > + "edited. Devices that are editable are: " > + "LVM logical volumes, LVM physical " > + "volumes, device partitions, and RAID " > + "devices."), > + custom_icon="error") > > # isNew implies that this request has never been successfully used before > def editRaidArray(self, raiddev, isNew = 0): Assuming we're going with the new strategy of warning the user when they do something that's not allowed (see the discussion about editing/deleting when nothing's selected), this is fine. I don't think "device partitions" makes any sense, though. I'd prefer it to just be "partitions". - Chris _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list