On 09/09/2009 11:16 AM, Hans de Goede wrote: > We're moving back to %post generation of dracut initrd's due to > GPL concerns about shipping pre build initrd's. This means the initrd > will no longer be truely generic. To reflect this and make clear it is > not an mkinitrd initrd, the name was changes to simply dracut.img. > --- > booty/bootloaderInfo.py | 2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > diff --git a/booty/bootloaderInfo.py b/booty/bootloaderInfo.py > index b2725ab..e91f2db 100644 > --- a/booty/bootloaderInfo.py > +++ b/booty/bootloaderInfo.py > @@ -308,7 +308,7 @@ class bootloaderInfo: > if os.access(instRoot + "/boot/" + initrd, os.R_OK): > return initrd > > - initrd = "initrd-generic%s.img" % kernelTag > + initrd = "dracut%s.img" % kernelTag > if os.access(instRoot + "/boot/" + initrd, os.R_OK): > return initrd > Well, bikeshedding about the name of the file aside, this is obviously a /correct/ patch. That being said, I'm with notting - it seems like a weird place to expose the "dracut" name to users. -- Peter Power corrupts. Absolute power is kind of neat. -- John Lehman, Secretary of the Navy, 1981-1987 _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list