Martin Gracik wrote:
Rewrote the devicelibs unittest baseclass so we can create and remove another loop devices within the tests. Rewrote the isRaidXY(raidlevel) functions in mdraid.py into one function isRaid(XY, raidlevel). Rewrote the get_raid_min_members and get_raid_max_spares functions to use the new isRaid function, and not use many if-elif-else statements. Changed the name of get_raid_min_members and get_raid_max_spares functions to match the name scheme of getRaidLevels and isRaid. Changed the minimum raid members for raid10 to 2. --- storage/devicelibs/mdraid.py | 81 ++++++++++++------------- tests/storage/devicelibs/baseclass.py | 60 ++++++++++--------- tests/storage/devicelibs/mdraid.py | 105 +++++++++++++++++++++++++++++++++ 3 files changed, 176 insertions(+), 70 deletions(-) create mode 100644 tests/storage/devicelibs/mdraid.py
looks good to me except for: <snip>
-def get_raid_max_spares(raidlevel, nummembers):
<snip>
+def getRaidMaxSpares(raidlevel, nummembers):
<snip> renamed get_raid_max_spares is used in iw/raid_dialog_gui.py Radek _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list