Yeah, i think this looks much better ----- "Joel Granados Moreno" <jgranado@xxxxxxxxxx> wrote: > --- > checkbootloader.py | 4 ++++ > 1 files changed, 4 insertions(+), 0 deletions(-) > > diff --git a/checkbootloader.py b/checkbootloader.py > index c78bfba..604d3fd 100644 > --- a/checkbootloader.py > +++ b/checkbootloader.py > @@ -158,6 +158,10 @@ def getBootloaderTypeAndBoot(instRoot = "/"): > # XXX I don't like this, but it's what the maintainer > suggested :( > if string.find(block, "GRUB") >= 0: > return ("GRUB", bootDev) > + elif instRoot != "/": > + block = getBootBlock(bootDev, "/") > + if string.find(block, "GRUB") >= 0: > + return("GRUB", bootDev) > > if haveLiloConf: > f = open(instRoot + liloConfigFile, "r") > -- > 1.5.4.5 > > _______________________________________________ > Anaconda-devel-list mailing list > Anaconda-devel-list@xxxxxxxxxx > https://www.redhat.com/mailman/listinfo/anaconda-devel-list _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list