ALSA PCM DOP Mode - DAC Support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I'm developing an ALSA based audio application.

The DSD audio file under test is fs64 DSD format 2 channel.

The file plays well under ALSA using my native DSD frame packer. It plays well using my DSD to PCM decoder and frame packer.

It is not playing using my DOP frame packer.

I'm reasonably confident I have ALSA format set up correctly..... - The ALSA format is set to S32_LE as the DAC supports this. - The ALSA sample rate set in for FS64 which should be 176k

cat /proc/asound/DX1/pcm0p/sub0/hw_params during a play:

access: RW_INTERLEAVED format: S32_LE subformat: STD channels: 2 rate: 176400 (176400/1) period_size: 22050 buffer_size: 88200

The 32 bit frames written to snd_pcm_writei() are packed as per DOP specification, so the buffer looks like this:

MSB LSB 0x5 0xd3 0x2c 0x0 0x5 0xd3 0x2c 0x0 0xfa 0xd2 0xd2 0x0 0xfa 0xd2 0xd2 0x0 0x5 0xd2 0xd2 0x0 0x5 0xd2 0xd2 0x0

There are no overflow or ALSA play errors; however with play all I get is a high pitched note to start, and then noise. I'm stumped.

The DAC is a Topping DX1 which has an XMOS USB interface and an AK4493S chip. I've also tried my Accuphase DAC-60 with the same result.

Documentation on this seems sparse.

- How can test if ALSA / Linux is putting the DAC into DOP mode? - How can I determine if the DAC or USB interface is supported by Debian (latest version) and controlling the DAC correctly?

Is there anything obvious I am missing here?


Alsa-user mailing list

[Index of Archives]     [ALSA Devel]     [Linux Audio Users]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

  Powered by Linux