Re: Onboard HDA/ALC898 works only after 60 second delay after booting

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



thanks for your reply.

On 2020-08-14 11:07, Kai Vehmanen wrote:
> Are you using the i915 driver at all? If 
> you load it (even if not using it for displays), that should help with the 
> delay as well.

I'm not using i915, but it is loaded by default. I also tried building
it into the kernel image for early loading, but the problem persisted.

Actually, I just discovered the only functioning work-around is quite
the opposite: blacklisting i915 on the kernel line. When blacklisting
i915 using /etc/modprobe.d, it still gets loaded for some reason, even
though it is not required by any other modules, and my problem persists.

But blacklisting it on the kernel line works, and then the 60s timeout

> For a quick workaround, 
> options snd_hda_codec_hdmi enable_acomp=N
I tried this (without applying the workaround above) and this had no
effect for me.

I'm considering to file a bug against the kernel driver, since a
hard-coded 60 second delay seems like very bad style to me in any scenario.

Best regards,

Alsa-user mailing list

[Index of Archives]     [ALSA Devel]     [Linux Audio Users]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

  Powered by Linux